SoftChalk
AT 311
CONTENT ADVANCED

2013/2014
# Table of Contents

**Overview** ......................................................................................................................... 4

**Advanced Content Items** ................................................................................................. 4

  - Accessibility ...................................................................................................................... 4
  - iFrame ................................................................................................................................. 4
    - Insert a Web Page .............................................................................................................. 4
    - Insert a PDF ..................................................................................................................... 6
  - Textpoppers ......................................................................................................................... 8
    - Insert a Text Only TextPopper ......................................................................................... 8
    - Insert a More Complex Textpopper ............................................................................... 9
    - TextPopper Options ......................................................................................................... 12
  - Math Characters and Equations ..................................................................................... 14
    - Math Characters .............................................................................................................. 14
    - Equation Editor .............................................................................................................. 15
  - Tables ................................................................................................................................. 17
    - Insert a table ................................................................................................................ 17
    - Add Rows or Columns .................................................................................................... 18
    - Merge Cells .................................................................................................................... 19
    - Column and Row Headers ............................................................................................ 19
    - Modify Column and Table Widths ................................................................................ 20
    - Style a Pasted Table ...................................................................................................... 21

**Advanced Style Properties** .............................................................................................. 22

  - Advanced Sidebars .......................................................................................................... 22
    - Format Text ................................................................................................................... 22
    - Enter a Hyperlink ........................................................................................................... 23
    - Enter Other Items .......................................................................................................... 24
    - Page Number .................................................................................................................. 24
    - Result ............................................................................................................................... 25
    - Text Only Sidebar .......................................................................................................... 25
    - Modify a Sidebar .............................................................................................................. 26
  - StyleBuilder ..................................................................................................................... 27
    - Overview ....................................................................................................................... 27
    - General Tab .................................................................................................................... 28
    - Banner Tab ..................................................................................................................... 29
    - Content Tab .................................................................................................................... 30
    - Sidebar Tab ..................................................................................................................... 31
    - Footer Tab ....................................................................................................................... 31
    - Save Your Personal Style ............................................................................................... 32
    - Modify a Personal Style ................................................................................................. 33
    - Export a Personal Style ................................................................................................. 33
    - Import a Personal Style ................................................................................................. 34
    - Delete a Personal Style ................................................................................................. 34
Library ................................................................. 35
  Save an Item to the Library ........................................ 35
    Save from a Lesson ............................................. 35
    Save from Media Search ....................................... 35
  Insert an Item in a Lesson ..................................... 36
  Edit a Library Item ............................................. 37
    Edit from the Library ........................................ 37
    Replace Edited Library Item ................................ 37
  Organize the Library ........................................... 38
  Export/Import Library Items ................................... 40
    Export Library Items .......................................... 40
    Import Library Items ......................................... 41
**Overview**

SoftChalk is a content development software program the DCCCD provides instructors and employees to create eCampus class content. SoftChalk makes it easy to include interactive learning activities, rich media and tests in one easy to navigate and attractive package.

**Advanced Content Items**

**Accessibility**

When you see this icon next to an item, there is an accessible option available. The user clicks on the icon and a page with the accessible version of the content loads.

**iFrame**

An iFrame allows you to embed a PDF file or website in your lesson. It provides a scrollable window.

**Insert a Web Page**

- Click your cursor where you want the iFrame.
- From the insert menu, select **iFrame**.
• Paste the URL in the **URL or File** box.

**NOTE:** Be sure to use the full URL which includes the http:// or https://.

• Modify the iFrame dimensions if desired.

A placeholder will appear on the SoftChalk lesson.

---

The scrollable webpage appears when the lesson is published or previewed.
Insert a PDF

You can easily insert a PDF in an iFrame. Office documents can’t be placed in iFrames, but a PDF version of them can.

- Click your cursor where you want to place the iFrame.
- From the insert menu, select iFrame.

- Click Select File.

- Navigate to the file.
- Select it by single clicking on it.
- Click Open.
The file path will appear in the URL or File box.

- Modify the **iFrame dimensions** if desired.
- Click **OK**.

An iFrame placeholder appears on your SoftChalk lesson.

The PDF file loads when previewed or published in a scrollable window.
Textpoppers are used to insert annotations which appear when the cursor hovers over a link. These annotations can contain text, images, media or hyperlinks.

**Insert a Text Only TextPopper**

To insert a TextPopper:

1. Highlight the desired text.
2. From the Insert menu, select TextPopper.
3. Enter your text in the bottom area of the editing window.
4. Click OK.
Result: When the cursor hovers over the Textpopper, the words appear in a window.

Insert a Complex Textpopper

You can include images, links, media and other items in a Textpopper. A Textpopper can have a title bar with content underneath.

- Highlight the desired text.
- From the **Insert** menu, select **Textpopper**.

To have a title bar, enter text in the **Top Area**.

To insert an item in the main Textpopper content area:

- Click your cursor in the window.
- Right-click and select the desired option. In the example, an image will be inserted in the window.
The **Insert Image** window will open.

- The image is selected using the **Select Image** button.
- Select **Image Attributes**
  - The image has been left aligned so text will wrap around it.
  - No **Border** has been selected and **V space** and **H space** are not available.
  - The **Long description** can be used as the alternative text for screen readers. If you use the Alternative text field, the alt text will show when the mouse hovers over the image.
  - You can change the width or height if desired. Remember, this image will be in a small pop-up window so keep it small.
- **Click OK.**

**HINT**: You can edit the image and its attributes by right-clicking on it in the TextPopper window and selecting Modify.
The text wraps around the image because the image was left-aligned.

To insert a text hyperlink:

- Highlight the desired text that will be the hyperlink.
- Right-click on it and select **Hyperlink**.

- To link to a PDF, select **Select File**, navigate to the file and select it.
- **OR**
  - To link to a Web Page, paste the URL in the **URL** box. Be sure to include the http:// or https://.
  - **Open the link in a new window** is the default and is the recommended setting.
- Click **OK**.
TextPopper Options

- Change the following options if desired:

1. **Background Style**: There are 8 different style options. Select the one that you want. Only the Original Style offers the Top Area. In the example the Original style is used.

![Background Style Options](image)

2. **Features**: The default Features are Dropshadow with the Textpopper appearing at the Bottom Right of the text. Modify the Features if desired.

3. **Minimum Width**: The Textpopper will expand to fit images and media. Set the Minimum Width desired. In this example the Textpopper window will be at least 400 pixels wide.

- Click **OK**.
Result: When the cursor hovers over the words, Thomas Edison, the Textpopper appears. The Textpopper contains an image, hyperlink and text. This is an effective way to provide supplemental information.
**Math Characters and Equations**

SoftChalk lets you insert math characters and equations in your lessons and QuizPoppers.

To insert Math Characters or Equations:
- Click your cursor where you want the characters or equation
- From the **Insert** menu, select **Math Characters** or **Equation**.

**NOTE:** These options are also available from the menu after right-clicking in a content area.

---

**Math Characters**

Click on the Math Character you want. You can click on multiple ones then click Close when finished.
Equation Editor

The Equation Editor provides an area to build an Equation.

- Enter your equation using the keyboard and available math forms and symbols.

- Each of the buttons contains different options. Click on the arrow, then select the desired option.
• Under **Insert** then **Layouts** there are several Layouts available.
• Include a description of the equation for accessibility in the provided box at the bottom right portion of the **Equation Editor**.
• Click **OK**.

You can right-click on the equation in the lesson and:
• Modify the equation
• Insert a Hyperlink
• Insert a Textpopper
• Or Save it to the Library.
Tables

Tables are used to organize content.

Insert a table

- Click your cursor where you want to place the table.
- From the Table menu, select Create Table.

- Set the desired number of Rows and Columns. Rows go across and columns go up and down.
- Set the Table width. **NOTE:** Do not set the Table width to 100% if using a Sidebar.
- Set the Table align if desired. None is the default. In the example the table will be placed against the left margin and text will flow around the table if desired. When None is selected, the text will not flow around the table.
- To use the table style associated with your selected Style, keep Use style table checked.
- Click OK.

**NOTE:** to set your own style uncheck Use styled table and use the settings as desired.
The table is placed where the cursor was. You can type in the table and format the text using the format options on the toolbar.

**NOTE**: Delete a table by clicking in the table and selecting Delete Table from the Table menu.

### Add Rows or Columns

If you did not create enough rows, when you reach the last cell in the last row a new row will be inserted when you click the Tab key on the keyboard.

To insert a row above a row:

- Click your cursor in the Row below the desired new row.
- From the **Table** menu, select **Row/Insert Row Above**.

There is now a blank row at the top of the table.

To insert Columns, place the cursor to the right of where you want a new column and use the Table/Column menu.

**NOTE**: You can also Delete rows and columns using the same menus.
**Merge Cells**

If you have a title that you want to go across the table, you can merge the cells.

- Click and drag your cursor to select the cells you want to merge.
- From the **Table** menu, select **Merge Cells**. The division between the cells is now gone.

**Column and Row Headers**

To make Columns or Rows Headers:

- Place your cursor in the desired cell or highlight a group of cells.

- From the **Table** menu, select **Cell/Make Column Header** or **Make Row Header**.
The top merged row is now a header row.

<table>
<thead>
<tr>
<th>Output Increases between 1865 and 1898</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Wheat</td>
<td>256%</td>
</tr>
<tr>
<td>Corn</td>
<td>222%</td>
</tr>
<tr>
<td>Coal</td>
<td>800%</td>
</tr>
<tr>
<td>Miles of Railroad Track</td>
<td>567%</td>
</tr>
</tbody>
</table>

**Modify Column and Table Widths**

You can modify the width of a Table by clicking in the table and selecting Table/Modify Table. You can also click and drag the boundary of a column to make it wider or narrower.

- Place your cursor in-between two columns, or the border of the edge of the table.
- Click and drag the cursor to expand the column.

The data now fits in the table better.
**Style a Pasted Table**

When you paste a table in SoftChalk, it pastes as a non-styled table. You can set it to match the style of the rest of your lesson.

- Click inside the pasted table.
- From the **Table** menu, select **Modify Table**.

- Click **Use styled table**.
- Click **OK**.

The table should now match any other styled tables in the lesson.
Advanced Style Properties

Advanced Sidebars

In addition to the “On This Page” sidebar, SoftChalk provides other sidebars: Handouts, Learn More, More Resources and Text Only. In the Text Only sidebar you can enter your own title.

**NOTE:** If you have both a table and a sidebar on the same page, set your table width to 99% or less.

To Create a Sidebar:

- From the **Properties** menu, select **Sidebar**.
- Select the desired **Sidebar**.

**Format Text**

- Once you have entered your text, you can highlight it, right-click and select **Format** from the menu.
Enter a Hyperlink

You can hyperlink to web pages or PDF files.

- Highlight the text for the hyperlink.
- Right-click and select **HyperLink**.

- To insert a URL, copy and paste the URL from the web browser into the **URL** box.

**OR**

- To insert a file, click **Select File**, navigate to the file and select it. The path will load in the **URL** box.
- Make sure **Open the link in a new window** is checked.
- Click **OK**.
Enter Other Items

You can enter any of the items in the list when you right-click on the content window.

Page Number

The sidebar will appear on the page you select. If you were already working on a particular page that will show in the For Page list.

- Select which page you want the sidebar to appear on

OR

- Click Copy to All Pages to have it appear on all pages.
- Click OK.
Result

You will not see any results on your SoftChalk file until you publish or preview it.

**NOTE**: You need to have a banner style selected to see any Sidebar.

The Learn More Sidebar shows on the page and contains hyperlinks to PDF documents.

### Text Only Sidebar

The **Text Only Sidebar** allows you to put in a Text title of your choosing. Content options are the same as other Sidebars.

**NOTE**: If you link to an Office file, SoftChalk will load the file in the program it was created in. It is recommended you use PDF files instead of Office files.
Modify a Sidebar

- To modify a Sidebar, select the type of sidebar you want to modify from Properties/Sidebar.

**NOTE:** A Sidebar will only show if you select the correct type. For example, if you initially selected a Learn More sidebar, you will not see that Sidebar if you then select Handouts from the menu.

- Select the Page the sidebar is located on.

- Modify the Sidebar.
- Click **OK**.

**NOTE:** To delete the Sidebar, select the Clear Text button.
**StyleBuilder**

**Overview**

You can use the StyleBuilder to create a personalized style for your lesson. You can also import a style someone else created.

To open the StyleBuilder:

- From the **Tools** menu, select **StyleBuilder**.

There are 5 tabs on the StyleBuilder.
General Tab

The General Tab is the starting point of creating a Personal Style. There is a preview of the Style you select.

- To create a new Personal Style, select a Template. Any Personal Styles you have already created will be in the list.

A preview of the Style can be seen.
Banner Tab

- You can personalize the Banner area using any of the available tools. When you make a change, you can preview the change in the window.

- To add a Logo, click the Logo check box and use the Choose button to navigate to your Logo.
Content Tab

- To modify any of the Content style colors and font use the options.
- To change a color, click on the button category you want to change.

- Use the **Choose Color** window to select a new color.
- Click **OK**.
Sidebar Tab

- Make any changes to the Sidebar using the options.

Footer Tab

- Make any changes to the Footer using the options.
Save Your Personal Style

- **Click** **Save As**.

- **Name the Style.**
- **Click** **OK**.

The new style will appear in your Personal Style section when Style Properties is selected from the Properties menu. You have to select it for any lesson you want to use it for.
Modify a Personal Style

- From the StyleBuilder, select the Personal Style you want to modify.
- Make your modifications.
- Click **Save**.
- You will need to re-apply the Style to your lessons for the changes to show.

Export a Personal Style

You can export a style to use on a different computer or to share with other users.

- From the **StyleBuilder** window, click **Export**.

- Navigate to the location you want to save the zip file.
- Name it.
- Click **Save**.

You can share this zip file with other users or your other computers.
Import a Personal Style

- From the **StyleBuilder** window, select **Import**.

- Navigate to the location of the zip style file and select it.
- Click **Open**.

The Style will now appear in your list of Personal Styles.

Delete a Personal Style

- From the **StyleBuilder** window, select the desired style from the Template menu.
- Click **Delete**.
Library

You can save images, media, equations, QuizPoppers, Quiz Groups and activities to the library to use later. You can export and import Library items to share with other computers or colleagues. The Library is accessed from the Tools menu.

Save an Item to the Library

Save from a Lesson

- From the SoftChalk lesson, right click on an item.
- Select **Save to Library**.

**NOTE:** When a QuizPopper from the Library is used in a Quiz Group, it will lose any point value previously assigned and will need to be edited in the Quiz Group to add a point value.

Save from Media Search

- Open **Media Search** from the **Tools** menu.
- Search for the desired media.
- Select the media by clicking on it.
- Click **Save to Library** then click **Close**.
**Insert a Library Item in a Lesson**

Once an item has been saved in the Library, it can be used in lessons.

- Click your cursor where you want to place the Library item.
- Open the **Library** from the **Tools** menu and select the desired item.
- Click **Insert Into Lesson** then close the Library.

### Library Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Activity" /></td>
<td>Activity</td>
</tr>
<tr>
<td><img src="image" alt="Equation" /></td>
<td>Equation</td>
</tr>
<tr>
<td><img src="image" alt="QuizPopper" /></td>
<td>QuizPopper</td>
</tr>
<tr>
<td><img src="image" alt="Widget" /></td>
<td>Widget (This one is from YouTube)</td>
</tr>
</tbody>
</table>
Edit a Library Item

Edit from the Library
From the Library, you can only edit the Title and Description.

- Click on the item you want to edit.
- Edit the **Title** or **Description**.
- Click **Save Edits**.

Replace Edited Library Item
If you edit an item you have saved in the Library, you can replace the previous version with the edited version.

- Right-click on an item in a SoftChalk lesson.
- Select **Modify**.
- Edit the item and save.
- Right-click on the updated item and select **Add to Library**.

- Complete the following steps:
  1. Click on the item you want to replace.
  2. Give it a **Name** and **Description**.
  3. Click **Replace Item**.
Organize the Library

You can add Folders to organize the Library. Use the + and – buttons or icons to expand and collapse folders.

In the example a folder named Hist 1301 has a subfolder named QuizPoppers. To make a new folder for the images:

- Click on the folder you would like to create a sub-folder in.
- Click **New Folder**.

- Type a **Name** or select one from the list.
- Type a **Description** if desired.
- Click **OK**.
• Click on an item you want to move in the folder.
• Drag it to the folder and hover over the folder.
• Make sure the folder name is highlighted and release the mouse button.

The image is now in the Images folder. You can continue to click and drag until all desired items are in the folder.

**HINT:** When saving in one of the Library’s folders, select the desired folder before you save.

**NOTE:** to delete a Library item, select it and click the Delete button.
Export/Import Library Items

Use the Export and Import features to share Library items between different computers or to share with Colleagues.

Export Library Items

- Select the folder you want to export. In the example the entire Library will be exported.
- Click **Export**.

- Navigate to the location where you want to save the file.
- Name the zip file.
- Click **Save**.
Import Library Items

- Select **Import** from the Library window.

- Navigate to the location of the saved Library zip file.
- Select the zip file.
- Click **Open**.

The Library items will import into your Library.